[docker] npmがインストールエラーになる時の対応

Pocket
LINEで送る
GREE にシェア
LinkedIn にシェア

こんにちわ。
 

下駄です。
 

「インストールエラー」とかけまして、
 

「受験生」と、ときます。
 

そのココロは・・・
 

問題解決に向けて頑張りましょう。

dockerでnpmがインストールできないトラブル

Dockerfileに以下のように記述していて、
 

buildをすると、以下のようなエラーが出ます。
 

 

解消までの道

「nodejs」やら「node-gyp」がすでにインストールされているので、エラーになっていると思って、簡易にインストール順番を変えてみても、同じエラーがでます。
 

おまけに、ゴミコンテナまで立ち上がって、非常に迷惑な症状です。
 

 

解決!

どうやら、”libssl1.0-dev”を事前にインスールしておかないとnpmインストールでエラーが出るということを、書いてあるサイトがありました。
 

ありがたや!!!
 

Dockerfileを以下のようにして、無事に問題解決することができました・・・とさ・・・
 

 

参考 : https://www.trifields.jp/how-to-install-node-js-on-ubuntu1804-3544

Leave a Reply

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です